Tillbaka till översikten
Avslutad

Main site of Jamster!/Jamba! Games & Apps Archive/Revival is down

Jun 12, 2026 at 4:33pm UTC
Påverkade tjänster
Main Site

Avslutad
Jun 12, 2026 at 4:44pm UTC

Update: We’re back! Jamster!/Jamba! Games & Apps Archive/Revival main site should be up and running.

Uppdaterad
Jun 12, 2026 at 4:39pm UTC

Update: We will be keeping the Jamster!/Jamba! Games & Apps Archive/Revival main site offline whilst we continue to investigate these issues that were reported.

Skapad
Jun 12, 2026 at 4:33pm UTC

We’re having some trouble with Jamster!/Jamba! Games & Apps Archive/Revival Main Site. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.